
 

 

 

ENGLISH VERSION 

Design the Vaccination Game Layouts – Part I 

Hi Everyone! Welcome to the intermediary course on game development. 

Are you excited to be a part of this? Let’s get started on yet another mission of saving humans. 

Right from birth, we are exposed to many different microbes like bacteria, virus, etc. Many are beneficial but 

some can cause diseases. 

The body's immune system helps protect us against infections. When we are exposed to infection, the immune 

system triggers a series of responses to neutralize the microbes and limit their harmful effects. Often exposure 

to many infectious diseases give us lifelong protection which we call immunity. And this prevents us from 

contracting the same disease again as our immune system “remembers” the microbe. 

However, some diseases may lead to serious complications and sometimes death. Vaccination (or immunization) 

is a way to build the body’s natural immunity to a disease before one gets sick. This keeps us from getting and 

spreading the disease. The aim of vaccination is to obtain this immunity without any of the risks of having the 

disease. 

When there is an epidemic the disease spreads rapidly and affects a significant amount of population. The rate 

of spread is called Ro (pronounced as R naught), and indicates how contagious an infectious disease is. It’s also 

referred to as the reproduction number. As an infection spreads to new people, the microbes reproduces itself.  

When we vaccinate, we activate the immune system's "memory." During vaccination, a weakened microbe, a 

fragment, or something that resembles it, is added to the body. The immune system is then activated without 

us becoming sick. Some dangerous infectious diseases can be prevented in a simple and effective way. When a 

majority of the population has been vaccinated against a disease, there will be few people left to whom the 

infection can spread. This protects the few who have not been vaccinated.  

So let’s get started with our next project. In this game, the population gets infected by a deadly virus which has 

a high reproduction rate or Ro. The game is about how each person is connected and will affect others in the 

form of a web. To begin with, everyone is infected with the disease and are unhealthy that is represented by a 

“red box”. The user has to generate a vaccine by pressing the injection button, which turns from black to green 

showing that it is ready to use for one time. To disinfect humans, you need to control the injection and vaccinate 

the infected people. Use the arrow keys to move the injection up, down, left & right, and the moment you make 

contact with one person, he / she also disinfects the others who are directly connected to him / her.  But 

remember the person remains disinfected only for 5 seconds and due to the proximity with others in the web 



 

 

he / she could again become infected. Therefore, you have the challenge to disinfect as many people as you can 

within the stipulated time of 90 seconds and for which you will get a chance to use only 6 vaccines at a time. The 

shortest time taken to disinfect all the humans will be the high score of the game. 

I am sure you are ready for this challenge. Let’s get started.  

We will begin by opening the Construct software. Once it is opened, click on “File” present in the top-menu bar 

and click on ‘New’. Select ‘New empty project’ option and click on ‘Open’. Just like our last project, a new game 

project opens and you can see Layout 1 & Event Sheet 1 on the screen. 

Similar to our last game, we need 5 screens here as well. So, let us first begin by creating these 5 layouts for the 

game. 

 Home Screen 

 Game Screen 

 Rule Screen 

 Restart Screen 

 Game Won Screen 

Just like we did in our last project, we will create 5 layouts and rename them and their event sheets accordingly. 

As the process is the same as previous project, we will fast track it. We would recommend you to download the 

video description to follow the step by step process, if forgotten. 

To create the layouts: 

Right-click on ‘Layout 1’ > Select ‘Rename’ > Rename it ‘Home Screen’ 

Go to right window pane > Right click on the ‘Layouts’ in Project window > Select ‘Add layout’ option > Click 

on ‘Add event sheet’ > ‘Layout 2’ is created > Rename it ‘Game Screen’ 

Go to right window pane > Right click on the ‘Layouts’ in Project window > Select ‘Add layout’ option > Click 

on ‘Add event sheet’ > ‘Layout 3’ is created > Rename it ‘Rule Screen’ 

Go to right window pane > Right click on the ‘Layouts’ in Project window > Select ‘Add layout’ option > Click 

on ‘Add event sheet’ > ‘Layout 4’ is created > Rename it ‘Restart Screen’ 

Go to right window pane > Right click on the ‘Layouts’ in Project window > Select ‘Add layout’ option > Click 

on ‘Add event sheet’ > ‘Layout 5’ is created > Rename it ‘Game Won Screen’ 

To create the layouts: 

Right-click on ‘Event sheet 1’ > Select ‘Rename’ > Rename it ‘Home Screen Code’ 



 

 

Right-click on ‘Event sheet 2’ > Select ‘Rename’ > Rename it ‘Game Screen Code’ 

Right-click on ‘Event sheet 3’ > Select ‘Rename’ > Rename it ‘Rule Screen Code’ 

Right-click on ‘Event sheet 4’ > Select ‘Rename’ > Rename it ‘Restart Screen Code’ 

Right-click on ‘Event sheet 5’ > Select ‘Rename’ > Rename it ‘Game Won Screen Code’ 

Before proceeding further, let’s save our project. To save the project, click on the file tab again and select ‘Save’ 

option. A new window will pop-up. Type File name ‘Vaccination Game’, browse for suitable location where you 

want to save your project and click on ‘Save’. Remember, if you close and reopen this project again, you will see 

that the Layouts automatically arranged themselves in alphabetical order.  

Next, let us download a custom images package that has been created especially for you all to use during the 

game creation. Copy the link from the description below and paste the link on your preferred browser. Click on 

download to start downloading the package. Also, you can use images downloaded from the internet as per 

your choice. 

Now, we’ll get down to designing our screens…. Let’s start with the ‘Home Screen’ first…  

Click on the Home screen layout tab present in the top bar. Once you select the Home screen layout, you will 

see the layout properties on the left window pane. In the properties section, change the layout size by changing 

the values to 854, 480 as this is the standard screen size for most of the systems.  

Just like last time, we’ll need the background screen and the Play & Rule button on this layout. To do that, follow 

the same steps as done in the last game after creating 2 layers.  

Add Background Screen: 

Double-click on the screen > Select ‘Sprite’ option – Name it ‘HomeImage’ > Click on ‘Insert’ > X sign appears – 

Left click on the screen > Click on ‘Load an image from file’ option > Select HomeImage from the system – Close 

the window – Resize and reposition on the screen using anchor points 

Add 2 Layers: 

Go to the layer section in projects window > Right-click on the Layer 0 > Click the ‘Add layer at top’ option > 

Layer 1 is appeared 

Right-click on ‘Layer 0’ > Select ‘Rename’ option > Rename it ‘Home Background Layer’ > Click on the ‘Lock’ to 

lock the layer 

Select ‘Layer 1’ > Right-click on ‘Layer 1’ > Select ‘Rename’ option > Rename it ‘Home Button Layer’ – Let this 

layer be selected 



 

 

Add Play Button: 

Go to the ‘Home Screen’ layout > Double-click on the screen > Select ‘Sprite’ option – Name it ‘PlayButton’ > 

Click on ‘Insert’ > X sign appears – Left click on the screen > Click on ‘Load an image from file’ option > Select 

HomeImage from the system – Close the window – Resize and reposition on the screen using anchor points 

Add Rule Button: 

Double-click on the screen > Select ‘OK’ button from Controls section – Name it ‘RuleButton’ > Click on ‘Insert’ 

Go to ‘Properties’ on the left pane > Go to Text option > Click on ‘OK’ - Change the text to ‘RULES’ > Resize and 

reposition on the screen using anchor points 

So, now you see we are done with the Home screen. In our next video, we will continue making changes to the 

other layouts of our game. 

Till then, Bye-Bye! See you in the next video! 

 

HINDI VERSION 

Design the Vaccination Game Layouts – Part I 

 

Hi Everyone! Game development पर intermediary course में आपका स्वागत है। 

क्या आप इसका part बनने के लिए excited हैं?  चलिय humans को save करने के एक और  mission 

को शुरू करते हैं। 

जन्म से ही, हम कई अिग-अिग microbes जैसे bacteria, virus etc.के contact में होते हैं। कई 

beneficial होते हैं िेककन कुछ बीमाररयों का कारण बन सकते हैं। body की immune system  हमें 

infections से save करने में help करती है। जब हम infection  के contact में होते हैं, तो immune system  

microbes को बेअसर करने और उनके harmful effects को कम करने के लिए   series of responses 

को trigger करती है। अक्सर कई infectious diseases के contact में आने से हमें lifelong protection 



 

 

लमिती है जजसे हम immunity कहते हैं। और यह हमें same disease  किर से होन से  रोकता है, क्योंकक 

हमारा  immune system  microbes  को  याद रखती है। 

but , कुछ  diseases  serious complications और कभी-कभी death का कारण बन सकते हैं। 

Vaccination (या immunization) एक disease होने से पहिे body की natural  immunity  को  बनाने 

का एक तरीका है। यह हमें disease के होने और िैिने से बचाता है। Vaccination का aim  इस immunity 

को disease होने के riskके बबना achieve करना है। 

जब एक epidemic होती है तो disease तेजी से िैिता है और populationकी एक significant amount 

को affect करता है। rate of spread को RO कहा जाता है ( इसे R naught  pronounce ककया जाता है), 

और ये बताता  है कक infectious  disease ककतना  contagious  है। इसे reproduction number भी बोिा 

जाता है। जैसे कक एक infection  नए िोगों में िैिता है, microbes  खदु reproduce करता है। 

जब हम Vaccination करते हैं, तो हम immune system  की “memory”को active करते हैं। Vaccination 

के दौरान, एक weak microbe, a fragment, या ऐसा कुछ जो इससे लमिता जुिता हो, body में जोडा 

जाता है। तब  बबना बीमार हुए immune system  active  हो जाती  है  कुछ dangerous infectious 

diseases को simple और effective तरीके से रोका जा सकता है। जब ज्यादातर  populationको एक 

disease के against  vaccine िगाया गया है, तो कुछ ही िोग बचे होते हैं, जजनसे infection  िैि सकता 

है। यह उन िोगों की protection करता है जजन्हें  vaccine नहीीं िगाया गया है। 

तो चलिए अपना next project शुरू करतें हैं । इस game में, population एक घातक  virus से  infected 

हो जाती है जजसमें reproduction rate या Ro होता है। game इस बारे में है कक हर person कैसे  आपस 

में जुडा हुआ है और कैसे web के form में दसूरों को affect करेगा। starting में , सभी  disease से infected 

होता है और unhealthy  होता है जजसे “red box” द्वारा कदखाया जाता है। user को injection button 



 

 

press करके एक vaccine  generate करना है, जो black से green  colour में बदि जाता है यह कदखाता 

है कक यह एक बार  use करने के लिए ready  है। humans को disinfect करने के लिए, आपको 

 injection को control करने और infected िोगों को vaccine िगाने की जरुरत है। injection को ऊपर, 

नीचे, leftऔर rightिे जाने के लिए arrow keys का use करें, और जजस moment आप एक person के 

साथ contact बनाते हैं, वह / वह दसूरों को भी disinfects कर देता है जो सीधे उसके / उसके साथ जुडे हुए 

हैं। िेककन याद रखें कक person केवि 5 second के लिए disinfects रहता है और web में दसूरों के साथ 

जुडे होने के कारण वह किर से infected हो सकता है। इसलिए, आपके पास 90 second के fix time के 

अन्दर जजतने िोग हैं, उन्हें  disinfects करने का challange है, और इसके लिए आपको एक बार में केवि 

6 vaccines  का use करने का मौका लमिेगा। सभी humans को disinfects करने का सबसे time  

gameका highscore होगा। 

मुझे भरोसा है कक आप इस challange के लिए ready हैं।आइए शुरू करें। 

हम Construct software open करके  शुरू करेंगे। इसे open करने के बाद, top-menu बार में present  

“file”पर clickकरें और ‘new’ पर clickकरें। ‘New empty project’  optionचनुें और  ‘open' पर clickकरें। 

हमारी lastproject की तरह, एक नया game project  open होगा और आप screen पर layout1 और 

event sheet1 देख सकते हैं। 

हमारे बपछिे game के  जैसे, हमें यहाीं भी 5 screen की जरुरत है। तो, चलिए सबसे पहिे game के लिए 

ये 5 layoutबनाकर शुरू करते हैं। 

 Home screen 

 Game screen 

 Rule screen 

 Restart Screen 



 

 

 Game Won Screen  

जैसे हमने अपने बपछिे project में ककया था, हम 5 layoutबनाएींगे और उनके according और उनके  

event sheet का नाम बदिेंगे। जैसा कक process बपछिे project जैसा ही same है, हम इसे fast  track 

करेंगे। अगर आप भूि गए हैं, तो हम आपको step by step process को follow करने के लिए video 

description download करने की सिाह देंगे। 

To create the layouts: 

Right-click on ‘Layout 1’ > Select ‘Rename’ > Rename it ‘Home Screen’ 

Go to right window pane > Right click on the ‘Layouts’ in Project window > Select ‘Add 

layout’ option > Click on ‘Add event sheet’ > ‘Layout 2’ is created > Rename it ‘Game Screen’ 

Go to right window pane > Right click on the ‘Layouts’ in Project window > Select ‘Add 

layout’ option > Click on ‘Add event sheet’ > ‘Layout 3’ is created > Rename it ‘Rule Screen’ 

Go to right window pane > Right click on the ‘Layouts’ in Project window > Select ‘Add 

layout’ option > Click on ‘Add event sheet’ > ‘Layout 4’ is created > Rename it ‘Restart Screen’ 

Go to right window pane > Right click on the ‘Layouts’ in Project window > Select ‘Add 

layout’ option > Click on ‘Add event sheet’ > ‘Layout 5’ is created > Rename it ‘Game Won 

Screen’ 

To create the layouts: 

Right-click on ‘Event sheet 1’ > Select ‘Rename’ > Rename it ‘Home Screen Code’ 

Right-click on ‘Event sheet 2’ > Select ‘Rename’ > Rename it ‘Game Screen Code’ 

Right-click on ‘Event sheet 3’ > Select ‘Rename’ > Rename it ‘Rule Screen Code’ 

Right-click on ‘Event sheet 4’ > Select ‘Rename’ > Rename it ‘Restart Screen Code’ 

Right-click on ‘Event sheet 5’ > Select ‘Rename’ > Rename it ‘Game Won Screen Code’  



 

 

आगे बढ़ने से पहिे, आइए अपना project सेव करें। project को save करने के लिए, file tab पर किर से 

clickकरें और ‘save’ optionचनुें। एक new windowकदखाई देगी। file नाम 'Vaccination game'  type 

करें, suitable location पर browse करें जहााँ आप अपनी project को save करना चाहते हैं और ‘save’ 

पर clickकरें। याद रखें, अगर आप  इस project को किर से close करते हैं और किर से open करते हैं, तो 

आप देखेंगे कक layout automatically  alphabetical order में arrange हो गया है 

इसके बाद, हम एक custom image package  download करते हैं जजसे especially  आपके लिय game 

creation  में use करने के  

लिय बनाया गया है। नीचे कदए गए description से link  copy करें और अपने पसींद के  browser पर link 

paste करें। package download करना शुरू करने के लिए download पर clickकरें। इसके अिावा, आप 

अपनी पसींद के according इींटरनेट से download की गई images का use कर सकते हैं। 

अब, हम अपनी screen design करेंगे ... पहिे 'home screen' के साथ शुरू करते हैं ... 

top barमें present home screen layout tab पर clickकरें। एक बार जब आप home screen layout 

चनु िेते हैं, तो आप left window panel पर layout properties देखेंगे। properties section, values 

को 854, 480 में बदिकर layout size बदिें क्योंकक यह most of the systems के लिए standard screen 

size है। 

बपछिी बार की तरह, हमें इस layoutपर background screen  और play Rule button की जरुरत होगी। 

ऐसा करने के लिए, दो layers को बनाने के बाद last  gameमें ककए गए steps को follow करें। 

Add Background Screen: 

Double-click on the screen > Select ‘Sprite’ option – Name it ‘HomeImage’ > Click on ‘Insert’ 

> X sign appears – Left click on the screen > Click on ‘Load an image from file’ option > Select 



 

 

HomeImage from the system – Close the window – Resize and reposition on the screen using 

anchor points 

Add 2 Layers: 

Go to the layer section in projects window > Right-click on the Layer 0 > Click the ‘Add layer 

at top’ option > Layer 1 is appeared 

Right-click on ‘Layer 0’ > Select ‘Rename’ option > Rename it ‘Home Background Layer’ > 

Click on the ‘Lock’ to lock the layer 

Select ‘Layer 1’ > Right-click on ‘Layer 1’ > Select ‘Rename’ option > Rename it ‘Home Button 

Layer’ – Let this layer be selected 

Add Play Button: 

Go to the ‘Home Screen’ layout > Double-click on the screen > Select ‘Sprite’ option – Name 

it ‘PlayButton’ > Click on ‘Insert’ > X sign appears – Left click on the screen > Click on ‘Load 

an image from file’ option > Select HomeImage from the system – Close the window – Resize 

and reposition on the screen using anchor points 

Add Rule Button: 

Double-click on the screen > Select ‘OK’ button from Controls section – Name it ‘RuleButton’ 

> Click on ‘Insert’ 

Go to ‘Properties’ on the left pane > Go to Text option > Click on ‘OK’ - Change the text to 

‘RULES’ > Resize and reposition on the screen using anchor points 

तो, अब  हमने home screen का काम परूा कर लिया है । हमारे next video में, हम अपने game के बाकी  

layout में changes करते रहेंगे। 

तब तक के लिए bye! लमिते हैं next video में! 

 


